Поддержка продуктов forwebm.net

SEO-TOOLS проект сайта SEO инструментов => FAQ, вопросы и ответы => Тема начата: beautylife от 10 Декабрь 2011, 04:54:35

Название: добавление информера
Отправлено: beautylife от 10 Декабрь 2011, 04:54:35
Подскажите, что делаю не так при добавлении информера, нажимаю добавить, выбираю файл, делаю надстройки, ставлю галочку добавить активным и нажимаю добавить, на странице информеров не показан сам файл а только концовка адреса и показано что он активен, но когда пытаешься получить информер, написано - Нет активных информеров!
Название: Re: добавление информера
Отправлено: forwebm от 12 Декабрь 2011, 13:35:54
- Проверьте, все ли права доступа на каталоги установлены правильно
- Для того, чтобы информер отображался в публичном разделе - он должен быть помещен в какой-либо `раздел`

>на странице информеров не показан сам файл а только концовка адреса и показано что он активен, но когда пытаешься получить информер, написано - Нет активных информеров!
данная ошибка может возникать только если не удается создать временное изображение (т.е на каталог информеров `временных файлов` не установлены права доступа 777)
Название: Re: добавление информера
Отправлено: blackcat от 13 Декабрь 2011, 12:54:43
Толи чтото сделал (врядли), толи раньше не обращал внимания (скорее всего)...
Добавил информеры апдейтов. Ну нормально все. Но при просмотре их списка (для выбора пользователями, например) в основном информере на этой странице сайт.ру/tools/updatesinformer/ (на остальных нормально) показываются знаки вопроса. Причем первое (ПР) нормально, а остальное вопросами.
В самом файле updates_block.tpl все нормально (строки отличаются только номерами 1,2,3,4).
Название: Re: добавление информера
Отправлено: forwebm от 14 Декабрь 2011, 17:49:21
Цитировать
Добавил информеры апдейтов. Ну нормально все. Но при просмотре их списка (для выбора пользователями, например) в основном информере на этой странице сайт.ру/tools/updatesinformer/ (на остальных нормально) показываются знаки вопроса.

адрес приведите, пожалуйста..
Название: Re: добавление информера
Отправлено: blackcat от 14 Декабрь 2011, 18:35:14
потерто..
Название: Re: добавление информера
Отправлено: forwebm от 14 Декабрь 2011, 19:01:59
Какие изменения проводили в файле `items/updates_block.tpl` ?
Название: Re: добавление информера
Отправлено: blackcat от 14 Декабрь 2011, 19:47:33
Никаких существенных изменений, что могло бы к такому привести.
На данный момент этот файл восстановил полностью из оригинального архива.
Название: Re: добавление информера
Отправлено: forwebm от 14 Декабрь 2011, 21:11:17
Никаких существенных изменений, что могло бы к такому привести.
На данный момент этот файл восстановил полностью из оригинального архива.

При восстановлении, файл был взят из темы, что используется? (в разных темах разные файлы)
p.s Если вы не вносили изменений в файлы ядра проекта - данные будут передаваться корректно (при условии, разумеется, что шаблоны построены без ошибок)

p.s
в данный момент по той ошибки, что отображается у Вас могу сказать:
- или изменения затронуло файлов каталога ядра
- или используется файл шаблоны для вывода апдейтов из другой темы

p.s Написал в ЛС пример, как можно проверить корректность данных..
Название: Re: добавление информера
Отправлено: blackcat от 14 Декабрь 2011, 22:08:13
В лс написал ответ проверки корректности данных (пока сам код оставил - посмотрите сами).
Файл, который вернул из архива, конечно, взял из нужного шаблона.
Так главное же что в информерах то нормально отображается (на этой же странице).
Название: Re: добавление информера
Отправлено: MATRIX от 17 Сентябрь 2012, 17:10:29
загружаю информер но он не отображается, на нужные папки в справке 777 выставлено, в чем проблема?
Название: Re: добавление информера
Отправлено: forwebm от 18 Сентябрь 2012, 06:46:31
>загружаю информер но он не отображается, на нужные папки в справке 777 выставлено, в чем проблема?

>на нужные папки в справке 777 выставлено
на нужные папки и все вложенные???

включена ли поддержка загрузки изображений вообще на сервере?

p.s
дайте, пожалуйста, ссылку на файл с <?php phpinfo() ?>
Название: Re: добавление информера
Отправлено: MATRIX от 20 Сентябрь 2012, 07:24:14
>загружаю информер но он не отображается, на нужные папки в справке 777 выставлено, в чем проблема?

>на нужные папки в справке 777 выставлено
на нужные папки и все вложенные???

включена ли поддержка загрузки изображений вообще на сервере?

p.s
дайте, пожалуйста, ссылку на файл с <?php phpinfo() ?>

сегодня проверил, сами картинки информеров в папке ftp://.../pfiles/generalinformers/   есть, то есть они нормально загружаются в папку, но не выводятся на сайте почему то

вот ссылка на пхп инфо http://www.pr-cy.biz/test.php (http://forwebm.net/forum/go.php?url=aHR0cDovL3d3dy5wci1jeS5iaXovdGVzdC5waHA=)
Название: Re: добавление информера
Отправлено: forwebm от 20 Сентябрь 2012, 17:08:58
Цитировать
Error: Unable to send file sprites.zip.epub. Output buffer contains the following text (typically warnings or errors):

Вероятно у Вас некорректно идет работа с графикой (возможно что-то отключено или недоступно из компонентов).
Для проведения теста мне потребуется временный доступ по ftp к каталогу, в который установлен проект (с правом на запись).
p.s
отпишите в ЛС.